Jump to content

When I repeat the events they sometime miss the bar


Recommended Posts

I have a problem with Cubase lately that realy pissed me off and I can't fix it.

 

I create an event or import an audio file, ok? Then I dublicate it or repeat it. The snap is activate, yet the events/files sometimes miss the bar by some microseconds.

Instead of being exactly at the start of each bar/beat/any quantize I'm using they start a bit sooner or later. And I'm talking about micro-microseconds here. The distance is so small that you can't hear the difference in more sounds, but in some sounds with short attack (like some kicks I'm using) you can notice it.

 

I've never noticed the problem in the past and I'm really curious why it's happening.

Now keep in mind that I use a pirate copy of Cubase SX that has already some problems (it crashes all the time).

Maybe because of that?

 

It's really annoying because although you can barely hear the difference I have to move every event and file manually to the exact start!

 

Any ideas?

Link to comment
Share on other sites

Here's an image to make more clear what I mean

 

Posted Image

 

The file at the red circle is not at the start of the beat, but slightly sooner. You can see that it's a very, very small amount of time, but still!

Like I said the snap is activated

Link to comment
Share on other sites

Could be that you accidently locked the track, check if the lock button is enabled..

 

Dunno what else it could be, from those screenshots the track should snap to measure 4.

 

Edit: You could also try to click on the Measure 4 to make the cursor snap to it, then left click the audiowaveform of 909kick3 to select it, right click on it and select Move To > Cursor.

Link to comment
Share on other sites

Could be that you accidently locked the track, check if the lock button is enabled..

 

Dunno what else it could be, from those screenshots the track should snap to measure 4.

The track is not locked for sure.

 

Maybe bad programming? :unsure:

Link to comment
Share on other sites

Edit: You could also try to click on the Measure 4 to make the cursor snap to it, then left click the audiowaveform of 909kick3 to select it, right click on it and select Move To > Cursor.

That's what I do now, but it's really annoying to do it for all the events! It takes so much time! :(

Link to comment
Share on other sites

The track is not locked for sure.

 

Maybe bad programming? :unsure:

Well it is pirated.. I've never see it happen to the retail thing.

 

If it started to happen just recently, you might of changed some global settings, on purpose or by mistake. Check the options, see if anything is changed if you can remember the settings you set.

Link to comment
Share on other sites

Well it is pirated.. I've never see it happen to the retail thing.

 

If it started to happen just recently, you might of changed some global settings, on purpose or by mistake. Check the options, see if anything is changed if you can remember the settings you set.

I never mess with the options and even If I did I simply can't remember the default settings :D

I guess I'll stick with the problem until I found the money to buy my authentic one.

 

 

Thanks for the help! :)

Link to comment
Share on other sites

Are you sure you're not copying and pasting? I have a similar problem when I copy and paste. It never lines up and I have to drag the data to the right place, at which point snap seldomly works and I have to manually type the correct location. When I repeat or duplicate it works fine, just as long as the segments are exact increments according to bars (4, 8, 16, etc.). I'm using C4 (legally purchased). I think of it as a moody girlfriend.

Link to comment
Share on other sites

Are you sure you're not copying and pasting? I have a similar problem when I copy and paste. It never lines up and I have to drag the data to the right place, at which point snap seldomly works and I have to manually type the correct location. When I repeat or duplicate it works fine, just as long as the segments are exact increments according to bars (4, 8, 16, etc.). I'm using C4 (legally purchased). I think of it as a moody girlfriend.

No, I only repeat or duplicate.

But even if I would copy/paste why experience such a problem as long snap is activated? :unsure:

Link to comment
Share on other sites

Maybe you have your snap set to too fine an increment?

I usually set my snap to bar or beat and rarely to 1/16 quantize.

After all the amount of time in the error is even smaller than the lower of the quantize I can snap. So technically it must not be happening! :D

Link to comment
Share on other sites

Not at home so don't have SX in front of me now so please forgive any incorrect terminology...

 

There are two reasons why this might be happening.

1) Incorrect snap point on audio event: Each audio event has a 'snap point', which defines the location within the event which will be aligned with the grid when the event is either quantised or moved. The snap point is shown as a vertical line on the event with an 'S' in the middle. Normally when you import or create a new audio file or event the snap point is at the very beginning of the event but you can move it by dragging it, in which case the next time you snap or quantise the event to the grid, the beginning of the event will appear to be out of alignment. You can only see the snap point at certain levels of zoom, and you need to be looking directly at the audio event, ie. you can't see it in the arrange window if the event is inside an audio part. It's possible you may have moved the snap point without realising it.

 

2) Cubase has a bug: When exporting audio back into the arrange window it is vital to remember that Cubase does not always export the length it is asked to; in fact I'm not sure if it ever does. The way around this is to put the event inside a part as soon as it has been exported, and drag the end of the part out and back so you're absolutely sure it ends exactly on a bar (or beat, or whatever is most appropriate). Then when you duplicate the audio part many times you can be sure it won't gradually go out of sync with the rest of the track.

 

I think it's most likely that you've discovered problem 2) here...

Link to comment
Share on other sites

Not at home so don't have SX in front of me now so please forgive any incorrect terminology...

 

There are two reasons why this might be happening.

1) Incorrect snap point on audio event: Each audio event has a 'snap point', which defines the location within the event which will be aligned with the grid when the event is either quantised or moved. The snap point is shown as a vertical line on the event with an 'S' in the middle. Normally when you import or create a new audio file or event the snap point is at the very beginning of the event but you can move it by dragging it, in which case the next time you snap or quantise the event to the grid, the beginning of the event will appear to be out of alignment. You can only see the snap point at certain levels of zoom, and you need to be looking directly at the audio event, ie. you can't see it in the arrange window if the event is inside an audio part. It's possible you may have moved the snap point without realising it.

 

2) Cubase has a bug: When exporting audio back into the arrange window it is vital to remember that Cubase does not always export the length it is asked to; in fact I'm not sure if it ever does. The way around this is to put the event inside a part as soon as it has been exported, and drag the end of the part out and back so you're absolutely sure it ends exactly on a bar (or beat, or whatever is most appropriate). Then when you duplicate the audio part many times you can be sure it won't gradually go out of sync with the rest of the track.

 

I think it's most likely that you've discovered problem 2) here...

 

Thanks for th reply Colin, but

 

1) If I had moved the snap point of the audio event that means that the error must be happening every time I duplicate or repeat it, right? Well like I said it happens only sometimes.

2)Like I said this is happening to midi events too.

 

 

BTW I just realized that this is happening when I select an area that contains events (midi or audio) and duplicate/repeat the area!

 

Here is what I mean:

 

I select an area that contains both midi and audio events. The snap is activated and set to bar.

Posted Image

 

Now I zoom in and you can see that all the events start at the exact 177 bar no sooner or later. Then I dublicate the area. Normally the events should start at the 209 bar but SOME TIMES they miss the bar. For example in this example didn't happen.

Posted Image

 

I guess it has to do with the area selection, but since snap is activated and set to bar how it's possible to select an area that doens't start on bar? :unsure:

Link to comment
Share on other sites

Maybe check the lengths of your midi/audio events - perhaps they are a little shorter or longer than the bar. So when you duplicate an event it snaps the end of the event to the bar, and the front is out of place.

 

hope his makes sense???

 

happens to me some times like this.

 

 

good luck!

Link to comment
Share on other sites

Yeah, repeating and duplicating, at least in C4, by default will copy the part being duplicated so that it starts immediately at the end of the original MIDI or audio segment, not at the next bar or beat. So it could be, as Mylo says, that your segments do not accord with exact bars. Seems that snap actually has little to do with the issue until you're dragging and placing the newly duplicated segment(s).

Link to comment
Share on other sites

Maybe check the lengths of your midi/audio events - perhaps they are a little shorter or longer than the bar. So when you duplicate an event it snaps the end of the event to the bar, and the front is out of place.

 

hope his makes sense???

 

happens to me some times like this.

 

 

good luck!

The problem is that it happens also with events that are in the exact same lenght.

 

Yeah, repeating and duplicating, at least in C4, by default will copy the part being duplicated so that it starts immediately at the end of the original MIDI or audio segment, not at the next bar or beat. So it could be, as Mylo says, that your segments do not accord with exact bars. Seems that snap actually has little to do with the issue until you're dragging and placing the newly duplicated segment(s).

 

I know what you mean. Yeah when I dublicate an event the new one will start at the end of the old one.

But what about when I dublicate an area? This should not happening! As you can see in the pics I uploaded, as long the snap is activated the new area must be set in a bar, right?

 

Thank you for all the help, but I'm starting to believe that it's a bad programming error. :(

Link to comment
Share on other sites

Yup. Cubase has lots of little bugs similar to that. Wouldn't surprise me. Use the Force.

Only duplicate parts, not areas or events, and make sure your parts start and end on exact beat divisions by manually moving the start and end points away from and back towards the points where you want them to be.

Link to comment
Share on other sites

Only duplicate parts, not areas or events, and make sure your parts start and end on exact beat divisions by manually moving the start and end points away from and back towards the points where you want them to be.

I already do that :)

 

I guess repeating/duplicating areas was the problem. Thanks everyone!

Link to comment
Share on other sites

This kind of shit happens all the time in Sonar.

I get stuff off by miliseconds and I have to manually drag to the snap point and it is a pain in the ass.

Total time killer, though once in place it can then be locked.

Link to comment
Share on other sites

This kind of shit happens all the time in Sonar.

I get stuff off by milliseconds and I have to manually drag to the snap point and it is a pain in the ass.

Total time killer, though once in place it can then be locked.

Maybe you're having the same problem as I have. The Snap options likes to change from Snap To to Snap By. It should always be at Snap To, unless you want to transfer a loop forward or backward by exactly one or more measures (if it's not synced to the timeline).
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...