Jump to content

My speakers make this popping sound


Recommended Posts

I bought some months ago a 2.1 Edifier speakers set. They make a popping sound all the time. It's annoying as hell.

I've searched many times in the past about solutions, but nothing works. I've said the wires might be loose-nope, the power cable may not be properly plugged in-nope, that there's something wrong with my soundcard or mother board.

 

Well the thing is that they keep makign that sound even when my pc is turned off. Plus my previous 2.1 speakers didn't make any sound with the same soundcard/motherboard.

 

Any idea what causes the problem?

Link to comment
Share on other sites

It could be that the speakers are damaged. Try pushing the bass elements in a little, do you hear / feel a "crunching" noise? Also check out your latency settings, if too low you can hear all kinds of popping noises, but if your last setup worked it might not be the problem. Try some other speakers and see if they make the same kind of noise.

 

edit: aww.. Didn't read your post throughoutly. The problem is definitely in your speaker setup. amplifier, Ac converter of the amplifier or the speakers themselves.

Link to comment
Share on other sites

edit: aww.. Didn't read your post throughoutly. The problem is definitely in your speaker setup. amplifier, Ac converter of the amplifier or the speakers themselves.

 

Which means I'm fucked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...