Jump to content

System exclusive problem


Recommended Posts

High!

>

> I have a big problem which I hope u can solve cause Im loosing my

nerves with it. Please be patient to read this, it extensive but I wanted

to give all information needed for solving the problem. And thank u for

your time in advance.

>

> First let me tell u my setup. Hardware: Creative labs Soundblaster

Live!, Alesis Micron synth and a Wave Idea Bitstream 3X MIDI controller.

Software used for testing: Cubase SX and MIDI-OX and sendSX.

>

> My problem is that I cant send system exclusive messages to Micron

via Bitstream(or directly).

>

> I connected my Micron MIDI IN port to the Bitstream MIDI OUT port

and when I send sysex file to the Bitstream USB IN port (it should

normally pass the data to the MIDI OUT) Bitstream send a message USB IN

OVERFLOW! I tried reverse the process to see what happens but its the same

...., only that this time, when Im sending sysex from the Micron,

Bitstream sends a message MIDI IN OVERFLOW! In this case the sysex data is

actually dumped on the computer in full, but what use of it if I cant

send it back?

>

> I have tried connecting Micron directly to the SB Live! MIDI IN/OUT

ports and same thing, I can send sysex to the computer but Micron wont

receive it when I send it back. Other functions work normally, I can

play notes, change banks, programs, etc. whether the signal is coming

from SB Live!->Micron, or SB Live!->Bitstream MIDI IN->MIDI THRU->Micron,

or Bitstream USB IN->MIDI OUT->Micron.

>

> Normally the Micron should display "Receiving..." and program should

be loaded but Micron does not respond at all to sysex files..

>

> Sometimes the notes stuck which points to the incomplete MIDI

data(probably cause the USB overflow).

>

> That overflow seems to be happening cause the Bitstream has only 12

bytes buffer for sysex messages as I understand it, but anyway I tried

to lower the buffer in MIDI-OX and again the same message USB oveflow..

>

> I would like to send sysex to Micron via Bitstream so I dont have to

switch the MIDI connections every time I send sysex(since Im using

Bitstream for controlling the Micron) and if I connect Micron directly I

have no physical point that the data is being sent which in the

Bitstreams case I do(LEDs flashing)..

>

> I think I have tried everything to make this work with no succes,

please if u have any other idea that would might solve the problem I

would be very thankfull..

>

> If nothing works I wouldnt be able to hear any of the Ions programs

that I have downloaded nor I would be able to backup my patches..

>

> The only option if nothing works I will be left is to manually

configure Ion program or backup I have dumped on a computer.. But I cant

restore all the Micron factory presets nor any of the Ion banks

manually(it would consume TOO MUCH time)..

>

> Once again please help, my production is suffering cause of this..

And happy new year!!!

Link to comment
Share on other sites

*Bump*

 

He still needs help with this I think.

Anyone here knows a solution?

:)

Link to comment
Share on other sites

  • 2 weeks later...

What is this 'Wave Idea Bitstream Midi controller' you use?

 

Midi is vary simplistic and should be kept as simple as possible.

I haven't actually had a studio up for a couple of years,but I used to be pretty good with it.

I just want to clarify a few things:

1. you have the midi channel set right (in port can be one or omni)

2. you are trying to send data like bank changes etc from your synth to your computer.

3. you realize that system exclusive means exactly that : you can't use it on another source, it is hardware dependant

 

 

I believe there is software that will save a midi dump if that is what you want to do.

Link to comment
Share on other sites

Okey, whos the manufacturer, what does this device do? Did you try and email this to your support? They couldnt answer your question? :( Midi-OX works fine for me all the time when sending and recieving sysex data... so it has to be the device that has to be set to something like "Recieve" somewhere in the menues. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...